Как исправить ошибку?

/ /

Регистрация: 27.09.2015

Сообщений: 7

1

Неправильный путь к файлу. Схема не зарегистрирована

27.09.2015, 04:08. Показов 23909. Ответов 13


Здравствуйте, уважаемые форумчане!

УТ 11.1.7.49.

При попытке установки последующего обновления выдается сообщение.
То же самое происходит при попытке выгрузки конфигурации в файл .cf

Стандартное Тестирование и исправление, а также утилита ошибок не выявляет.
Выгрузка и загрузка (.dt) тоже проходит без проблем.

Подскажите, пожалуйста, может кто сталкивался с подобной проблемой?

Миниатюры

Неправильный путь к файлу. Схема не зарегистрирована
 

__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь





Эксперт 1С

841 / 604 / 211

Регистрация: 24.07.2013

Сообщений: 2,098

27.09.2015, 08:02

2

Попробуй протестировать саму конфигурацию:
Конфигурация -> Проверка конфигурации



1



/ /

Регистрация: 27.09.2015

Сообщений: 7

27.09.2015, 12:56

 [ТС]

3

Спасибо за совет!

Подскажите, пожалуйста, дальнейшие действия над результатами проверки.

Миниатюры

Неправильный путь к файлу. Схема не зарегистрирована
 





Эксперт 1С

841 / 604 / 211

Регистрация: 24.07.2013

Сообщений: 2,098

27.09.2015, 13:17

4

Это могут быть проблемы типовой конфигурации.

Обновление поставилось?





/ /

Регистрация: 27.09.2015

Сообщений: 7

27.09.2015, 13:28

 [ТС]

5

Не ставится. Выскакивает та же ошибка.





340 / 315 / 43

Регистрация: 20.08.2014

Сообщений: 1,242

Записей в блоге: 1

28.09.2015, 17:03

6

HIPPOza, почистить кэш для начала.





/ /

Регистрация: 27.09.2015

Сообщений: 7

28.09.2015, 23:39

 [ТС]

7

1c-k, спасибо! Это было сделано в первую очередь.





340 / 315 / 43

Регистрация: 20.08.2014

Сообщений: 1,242

Записей в блоге: 1

29.09.2015, 00:06

8

HIPPOza, тогда надо схему скд проверять.

Добавлено через 35 секунд
HIPPOza, если всё таки не проедет на последнюю версию, дождаться следующей и не биться головой об стену. 1с такой 1с.





/ /

Регистрация: 27.09.2015

Сообщений: 7

29.09.2015, 13:20

 [ТС]

9

Цитата
Сообщение от 1c-k
Посмотреть сообщение

HIPPOza, если всё таки не проедет на последнюю версию, дождаться следующей и не биться головой об стену. 1с такой 1с.

Дык она ни на какую не обновляется! На первом этапе стреляется с вышеуказанной ошибкой.
Подобно как и при выгрузке в файл .cf

Как вычислить эту ссылку, убить ее, вычистить или еще что? Вот в чем вопрос.





340 / 315 / 43

Регистрация: 20.08.2014

Сообщений: 1,242

Записей в блоге: 1

29.09.2015, 13:26

10

HIPPOza, в файловом варианте chkdbl запускался? только на копии обязательно.





Модератор

Эксперт 1С

3651 / 2880 / 562

Регистрация: 10.03.2011

Сообщений: 11,283

Записей в блоге: 1

29.09.2015, 15:05

11

HIPPOza, если chkdbl не поможет, (сохранив конфигурацию поставщика в файл) попробуйте загрузить конфигурацию из файла





/ /

Регистрация: 27.09.2015

Сообщений: 7

30.09.2015, 12:09

 [ТС]

12

Если имеется ввиду chdbfl.exe, и ее тоже использовал. Рапортует об успешной проверке. Ошибка при обновлении или выгрузке конфы в .cf осталась.

Подскажите, пожалуйста, как сохранить конфигурацию поставщика в файл?





Эксперт 1С

841 / 604 / 211

Регистрация: 24.07.2013

Сообщений: 2,098

30.09.2015, 12:44

13

Цитата
Сообщение от HIPPOza
Посмотреть сообщение

Подскажите, пожалуйста, как сохранить конфигурацию поставщика в файл?

Конфигурация -> Поддержка -> Настройка поддержки -> Сохранить



1



/ /

Регистрация: 27.09.2015

Сообщений: 7

01.10.2015, 03:09

 [ТС]

14

Попробовал. Как ни печально, та же ошибка, на том же месте ((

Вот лог обновления:

Добавлено через 33 минуты
{OK } Файл скрипта: “C:\Temp\1Cv8Update.1507061059 14\splash.hta”
{OK } Количество файлов обновления: 1
{OK } 1. C:\Program Files (x86)\1cv8\templates\1c\trade\ 11_1_7_56\1cv8.cfu
{OK } Завершение работы пользователей…
{OK } Cоздание резервной копии информационной базы…
{OK } Резервной копия базы создана
{OK } Загрузка файла обновления в основную базу (1/1)…
{OK } Запускается: C:\Program Files (x86)\1cv8\8.3.6.1999\bin\1cv8 .exe; параметры: CONFIG /F”D:\Base” /N”Администратор” /P”password” /WA- /UpdateCfg “C:\Program Files (x86)\1cv8\templates\1c\trade\ 11_1_7_56\1cv8.cfu” /Out “templog.txt” /UCПакетноеОбновлениеКонфигурац ииИБ /DisableStartupMessages; окно: SW_SHOW; ожидание: true
{ERR} Код возврата: 1
Неправильный путь к файлу ‘b81440cb-0″fe-4b6c-9ab8-c61d76bfca7d.0’. Схема не зарегистрирована
{OK } Запускается: C:\Program Files (x86)\1cv8\8.3.6.1999\bin\1cv8 .exe; параметры: CONFIG /F”D:\Base” /N”Администратор” /P”password” /WA- /LoadCfg “C:\Program Files (x86)\1cv8\templates\1c\trade\ 11_1_7_56\1cv8.cfu” /Out “templog.txt” /UCПакетноеОбновлениеКонфигурац ииИБ /DisableStartupMessages; окно: SW_SHOW; ожидание: true
{ERR} Код возврата: 1
Для выполнения команды требуется разблокировать все объекты.
{ERR} Завершение с ошибкой. Код ошибки: 1. Подробности см. в предыдущей записи.
{OK } Восстановление информационной базы…
{OK } База данных восстановлена из резервной копии
{OK } Начат сеанс внешнего соединения с ИБ
{OK } Запускается: C:\Program Files (x86)\1cv8\8.3.6.1999\bin\1cv8 c.exe; параметры: ENTERPRISE /F”D:\Base” /N”Администратор” /P”password” /WA-; окно: SW_SHOW; ожидание: false
{OK } Код возврата: 0





/ /

Регистрация: 14.02.2010

Сообщений: 25

1

Проблема с обновлением БГУ

10.04.2012, 18:10. Показов 6747. Ответов 16


Версия базы данных: Бухгалтерия государственного учреждения, редакция 1.0 (1.0.8.2)
Версия основной конфигурации: Бухгалтерия государственного учреждения, редакция 1.0 (1.0.10.2)
База данных не обновляется.
Дублирование имени объекта метаданных:
ПланВидовХарактеристик.ВидыСуб контоБюджет: Тип предопределенного вида характеристики не соответствует типу плана вида характеристики(ПрочиеДоходыИРа сходы)
ПланВидовХарактеристик.ВидыСуб контоБюджет: Тип предопределенного вида характеристики не соответствует типу плана вида характеристики(РасходыБудущихП ериодов)
ПланВидовХарактеристик.ВидыСуб контоБюджет: Тип предопределенного вида характеристики не соответствует типу плана вида характеристики(УсловияПоступле нияИВыбытия)
При проверке метаданных обнаружены ошибки!
Операция не может быть выполнена.

Tue Apr 10 14:46:00 UTC+0300 2012 {ERR} Завершение с ошибкой. Код ошибки: 101. Подробности см. в предыдущей записи.

Просто какой-то умник влез и снял защиту. Помогите решить бпроблему с обновлением. Либо как вернуть защиту обратно…в общем трабла та еще…

__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь





145 / 145 / 3

Регистрация: 25.03.2011

Сообщений: 512

10.04.2012, 18:58

2

Снимаете с поддержки и загружаете сф последнего релиза с итс



1



/ /

Регистрация: 14.02.2010

Сообщений: 25

10.04.2012, 19:11

 [ТС]

3

Вот, а не поможел ли сделать следующее. Установить чистую базу и перегнать все основные, забаланс, остатки и т.д. с той которая не обновляется в чистую? и потом обновлять или это бредово?





145 / 145 / 3

Регистрация: 25.03.2011

Сообщений: 512

10.04.2012, 20:29

4

Цитата
Сообщение от priorat
Посмотреть сообщение

Вот, а не поможел ли сделать следующее. Установить чистую базу и перегнать все основные, забаланс, остатки и т.д. с той которая не обновляется в чистую? и потом обновлять или это бредово?

Эмм, остатки переносят с начала года обычно а не во 2 квартал. Но если не волнует это, то можно и по вашему варианту.





/ /

Регистрация: 14.02.2010

Сообщений: 25

10.04.2012, 20:45

 [ТС]

5

Цитата
Сообщение от wade25
Посмотреть сообщение

Эмм, остатки переносят с начала года обычно а не во 2 квартал. Но если не волнует это, то можно и по вашему варианту.

Это как вариант. Прост если не ставить обновы то. Первое не сдадим годовой, полугодовой, отгребем от начальства. Выюора нет. Будем или или…





145 / 145 / 3

Регистрация: 25.03.2011

Сообщений: 512

10.04.2012, 21:23

6

Цитата
Сообщение от priorat
Посмотреть сообщение

Это как вариант. Прост если не ставить обновы то. Первое не сдадим годовой, полугодовой, отгребем от начальства. Выюора нет. Будем или или…

Нуьсделайте обнову как я сказал накатив сф, данные сохрантся, в чем проблема то?





6 / 6 /

Регистрация: 23.08.2010

Сообщений: 47

11.04.2012, 07:53

7

Здравствуйте!Пришлите выгрузку базы и файл обновления на mm1ck@ya.ru.Обновлю





2953 / 1765 / 82

Регистрация: 03.11.2011

Сообщений: 8,280

11.04.2012, 09:48

8

Цитата
Сообщение от priorat
Посмотреть сообщение

Вот, а не поможел ли сделать следующее. Установить чистую базу и перегнать все основные, забаланс, остатки и т.д. с той которая не обновляется в чистую? и потом обновлять или это бредово?

Не бредово. Я этим пользуюсь иногда. А иногда это единственный путь спасения. Использую типовую обработку обмена между аналогичными конфами.





/ /

Регистрация: 14.02.2010

Сообщений: 25

11.04.2012, 21:27

 [ТС]

9

Цитата
Сообщение от wade25
Посмотреть сообщение

Нуьсделайте обнову как я сказал накатив сф, данные сохрантся, в чем проблема то?

Извените не влядею всей терминологией что такое СФ? и как его накатить… я только начал вникать в 1С и хз что к чему.





6 / 6 /

Регистрация: 23.08.2010

Сообщений: 47

11.04.2012, 21:43

10

Хорошо гуглом поработаю СФ это файл конфигурации cf. формируетсяя в режиме конфигуратора.Меню конфигурация- выгрузить конфигурацию в файл… Ввот про этот файл речь и идет.Накатить Это в том же конфигураторе конфигурация -Загрузить конфигурацию из файла





2953 / 1765 / 82

Регистрация: 03.11.2011

Сообщений: 8,280

11.04.2012, 21:55

11

Цитата
Сообщение от priorat
Посмотреть сообщение

Извените не влядею всей терминологией что такое СФ? и как его накатить… я только начал вникать в 1С и хз что к чему.

СФ – это Счет-Фактура. Но имеется в виду файл 1cv8.cf, содержащий структуру метаданных, ещё называемый “конфа”, “цээфка”. Если запустить твою базу в режиме конфигуратора и далее Конфигурация/
Загрузить конфигурацию из файла – система запросит именно её. Этот процесс и называется “накатить сверху”. ОПАСНО! Должна быть полная уверенность в соответствии версий и в том, что не было объединений с разработками сторонних программеров.
Но это реальный способ восстановить поддержку.
Есть ещё режим просто “накатить”: Сравнить, объединить с конфигурацией из файла. Здесь большая свобода манёвра, но каким образом при объединении определяются приоритеты поддержки – я не знаю, вернее, думаю, что система оставляет текущие настройки в базе без предоставления выбора.
Кто подскажет, может?

Добавлено через 2 минуты
Но я ещё думаю, что кто-то поковырялся в конфигурации





145 / 145 / 3

Регистрация: 25.03.2011

Сообщений: 512

11.04.2012, 22:14

12

Цитата
Сообщение от mm1ck
Посмотреть сообщение

Хорошо гуглом поработаю СФ это файл конфигурации cf. формируетсяя в режиме конфигуратора.Меню конфигурация- выгрузить конфигурацию в файл… Ввот про этот файл речь и идет.Накатить Это в том же конфигураторе конфигурация -Загрузить конфигурацию из файла

Ответил в ЛС.





/ /

Регистрация: 07.07.2012

Сообщений: 5

07.07.2012, 11:02

13

Это все хорошо работает с профом, а что если надо БГУ 8.2 базовая обновить?
P.S: Там даже загрузить конфигурацию из файла не возможно(просто данного пункта меню нет). Конфигурацию я тоже не нашел как редактировать.

Добавлено через 12 минут
Я даже следующий вариант расматривал ,а что если создать чистую базу из шаблона и дальше ее обновлять ну к примеру у меня обновление 1.0.6.3 (и оно ни как не хочет обновлятся),а создать базу хотел из шаблона 1.0.7.2. Но столкнулся со следующей проблемой Базовая ни в какую не хочет видить другие шаблоны кроме своего 1.0.6.3. Так же пробовал по другому создал читую базу на другой 1с , сначала с обновлением 1_0_12_2, а потом 1.0.7.2, но при подключении к Базовой она требует ключ. Через конфигуратор Администрирование-загрузить информационную возникает такая же ситуация с ключем. Как бы я не маялся ни как не смог обновить её.





900 / 877 / 8

Регистрация: 15.03.2012

Сообщений: 2,680

07.07.2012, 17:34

14

Цитата
Сообщение от Must_Die
Посмотреть сообщение

Это все хорошо работает с профом, а что если надо БГУ 8.2 базовая обновить?
P.S: Там даже загрузить конфигурацию из файла не возможно(просто данного пункта меню нет). Конфигурацию я тоже не нашел как редактировать.
Добавлено через 12 минут
Я даже следующий вариант расматривал ,а что если создать чистую базу из шаблона и дальше ее обновлять ну к примеру у меня обновление 1.0.6.3 (и оно ни как не хочет обновлятся),а создать базу хотел из шаблона 1.0.7.2. Но столкнулся со следующей проблемой Базовая ни в какую не хочет видить другие шаблоны кроме своего 1.0.6.3. Так же пробовал по другому создал читую базу на другой 1с , сначала с обновлением 1_0_12_2, а потом 1.0.7.2, но при подключении к Базовой она требует ключ. Через конфигуратор Администрирование-загрузить информационную возникает такая же ситуация с ключем. Как бы я не маялся ни как не смог обновить её.

А проблема то у Вас в чем? Выше по тексту проблемы были из-за того, что конфигурация была измененная. Базовую изменить нельзя. Что у Вам выдает при обновлении?





/ /

Регистрация: 07.07.2012

Сообщений: 5

07.07.2012, 21:08

15

Цитата
Сообщение от Fenomen
Посмотреть сообщение

А проблема то у Вас в чем? Выше по тексту проблемы были из-за того, что конфигурация была измененная. Базовую изменить нельзя. Что у Вам выдает при обновлении?

БГУ 8.2 БАЗОВАЯ ни как не хочет обновлятся. при попытке обновить её с версии 1.0.6.3 до версии 1.0.7.3 пишет что данное обновление только для БГУ 1.0.6.3(каким она и является).
P.S Других для базовой конфигурации обновлений на сайте users.v8.1c.ru я не нашел. Пользователь на данном сайте не зарегистрирован.





900 / 877 / 8

Регистрация: 15.03.2012

Сообщений: 2,680

07.07.2012, 21:56

16

В конфигураторе: Конфигурация – Поддержка – Настройка поддержки. Там какой релиз указан?





/ /

Регистрация: 07.07.2012

Сообщений: 5

09.07.2012, 04:40

17

Цитата
Сообщение от Fenomen
Посмотреть сообщение

В конфигураторе: Конфигурация – Поддержка – Настройка поддержки. Там какой релиз указан?

Бухгалтерия гос учериждений 1.0.6.3. Это только данные из справки. А так там даже такой менюшки нет. Базовая там много чего нет в отличии от проф в этом то и проблема.

Добавлено через 14 минут

Цитата
Сообщение от Must_Die
Посмотреть сообщение

Бухгалтерия гос учериждений 1.0.6.3. Это только данные из справки. А так там даже такой менюшки нет. Базовая там много чего нет в отличии от проф в этом то и проблема.

Бухгалтерия гос учериждений базовая 1.0.6.3





rashid

27.02.20 – 06:35

При автоматическом обновлении 1С Бухгалтерия версий 3.0.75.100 Платформа 8.3.16.1224 происходит зацикливание.
Происходит периодическое сохранение базы, загрузка обновления -после вылетает и все повторяется. Это происходит и на Windows 7 и с другими базами в Windows 10.

Вот  лог:

27.02.2020 09:25:53 {OK} Используется COM соединение: true

27.02.2020 09:25:53 {OK} Запускается: regsvr32.exe; параметры: /n /i:user /s “C:\Program Files\1cv8\8.3.16.1224\bin\comcntr.dll”; окно: SW_HIDE; ожидание: true

27.02.2020 09:25:53 {OK} Код возврата: 0

27.02.2020 09:25:53 {OK} Файл скрипта: C:\Users\RashidViktorovich\AppData\Local\Temp\1Cv8Update.200227092059\splash.ht

27.02.2020 09:25:53 {OK} Количество файлов обновления: 1

27.02.2020 09:25:53 {OK} 1. D:\Base\tmplts\1c\Accounting\3.0.75.104\1cv8.cfu (Обязательная)

27.02.2020 09:25:54 {OK} Завершение работы пользователей…

27.02.2020 09:25:56 {OK} Создание резервной копии информационной базы…

27.02.2020 09:25:57 {OK}

      Выполняется копирование из:

      D:\Base\ГранитСтрой\1Cv8.1CD

      в:

      D:\Base\Архив\Гранит_Строй\1Cv81582759553483.1CD

27.02.2020 09:26:04 {OK} Резервная копия базы создана

27.02.2020 09:26:07 {OK} Загрузка файла обновления в основную базу (1/1)…

27.02.2020 09:26:08 {OK} Запускается: C:\Program Files\1cv8\8.3.16.1224\bin\1cv8.exe; параметры: CONFIG /F”D:\Base\ГранитСтрой” /N”” /P”******” /WA- /UpdateCfg “D:\Base\tmplts\1c\Accounting\3.0.75.104\1cv8.cfu” /Out “templog.txt” /UCПакетноеОбновлениеКонфигурацииИБ /DisableStartupMessages /DisableStartupDialogs; окно: SW_SHOW; ожидание: true

27.02.2020 09:28:24 {OK} Код возврата: 0

Обновление конфигурации успешно завершено

27.02.2020 09:28:25 {OK} Обновление конфигурации информационной базы (1/1)…

27.02.2020 09:28:26 {OK} Запускается: C:\Program Files\1cv8\8.3.16.1224\bin\1cv8.exe; параметры: CONFIG /F”D:\Base\ГранитСтрой” /N”” /P”******” /WA- /UpdateDBCfg -server /Out “templog.txt” /UCПакетноеОбновлениеКонфигурацииИБ /DisableStartupMessages /DisableStartupDialogs; окно: SW_SHOW; ожидание: true

27.02.2020 09:29:09 {OK} Код возврата: 0

Обновление конфигурации базы данных

Обработка структуры базы данных…

Сбор служебной информации…

Объект изменен: Справочник.ВидыОтправляемыхДокументов

Регистрация изменена: Справочник.ВидыОтправляемыхДокументов

Принятие изменений…

Обновление конфигурации базы данных успешно завершено

Построение индекса справки…

27.02.2020 09:29:10 {OK} Выполнение обработчиков обновления (1/1)…

27.02.2020 09:29:11 {OK} Запускается: wscript.exe; параметры: “C:\Users\RashidViktorovich\AppData\Local\Temp\1Cv8Update.200227092059\add-delete-patches.js” /ConnectionString:”File=’D:\Base\ГранитСтрой’;Usr=”;Pwd=’******’;UC=ПакетноеОбновлениеКонфигурацииИБ” /COMConnectorName:”v83.COMConnector” /FixFileNames:”” /RemoveFixNames:”” /Out:”C:\Users\RashidViktorovich\AppData\Local\Temp\1Cv8Update.200227092059\templog.txt”; окно: SW_HIDE; ожидание: true

27.02.2020 09:30:06 {ERR} Код возврата: -1073741819

27.02.2020 09:30:06 {ERR} Исключение при вызове ОбновлениеКонфигурацииВызовСервера.ОбновитьИсправленияИзСкрипта: Error, Не удалось обновить исправления конфигурации. Подробности см. в предыдущей записи..

27.02.2020 09:30:07 {ERR} Завершение с ошибкой. Код ошибки: 2. Подробности см. в предыдущей записи.

27.02.2020 09:30:07 {OK} Восстановление информационной базы…

27.02.2020 09:30:07 {OK} Восстановление ИБ из временного архива

27.02.2020 09:30:26 {OK} База данных восстановлена из резервной копии

27.02.2020 09:30:26 {OK} Начат сеанс внешнего соединения с ИБ

27.02.2020 09:30:29 {OK} СоединенияИБ.РазрешитьРаботуПользователей()

КАК ЭТО Победить?

Sergz66

1 – 27.02.20 – 06:44

Запустить уже конфигуратор и обновиться там.

famnam

2 – 27.02.20 – 06:47

(0) Похоже установлены какие-то исправления/патчи? Попробуйте удалить их

rashid

3 – 27.02.20 – 06:58

Конфы не дописаны, Для бухгалтеров каждый вызов программиста – нож по я…  Ведь так было хорошо раньше,  буквально месяц назад, кнопочкой далее, далее …

А так через конфигуратор да еще несколько баз, да на разных компах. Причем некоторые обновляются вроде автоматически, когда бубном постучишь. Это конечно не дело.

Vstur

4 – 27.02.20 – 07:10

(3) новые реалии, привыкайте….

времена, когда все работало, ушли в прошлое, теперь другое, абс. противоположное время, и конца ему, судя по всему, не видно….

Пробел

5 – 27.02.20 – 07:22

(0) Зайдите в конфигуратор и отключите расширения (если мне не изменяет склероз: Конфигурация -> Расширения -> снять галочку)

zak555

6 – 27.02.20 – 07:30

Что в жр написано ?

rashid

7 – 27.02.20 – 08:07

Расширений нет.
В ЖР пишет, что все обновление прошло нормально, Ни одной ошибки.

rashid

8 – 27.02.20 – 08:19

При вылете пишет Прекращена работа программы “Microsoft@Windows Based Script Host”

Сигнатура проблемы:

  Имя события проблемы:    APPCRASH
  Имя приложения:    wscript.exe
  Версия приложения:    ...
  Отметка времени приложения:    a5bca28
  Имя модуля с ошибкой:    core83.dll
  Версия модуля с ошибкой:    ...
  Отметка времени модуля с ошибкой:    e4378d3
  Код исключения:    c0000005
  Смещение исключения:    e1
  Версия ОС:    .......
  Код языка:    
  Дополнительные сведения :    bee
  Дополнительные сведения :    bee10b247e09b4afe24ac1aa06bb661
  Дополнительные сведения :    
  Дополнительные сведения :    d9bdbfebfeb881451717ceb3f617

Ознакомьтесь с заявлением о конфиденциальности в Интернете:

  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0419

Если заявление о конфиденциальности в Интернете недоступно, ознакомьтесь с его локальным вариантом:
  C:\Windows\system32\ru-RU\erofflps.txt

rashid

9 – 27.02.20 – 08:21

Далее Следующий вылет - Прекращена работа программы "Microsoft@ HTML приложение"

С сообщением:

Сигнатура проблемы:
  Имя события проблемы:    APPCRASH
  Имя приложения:    mshta.exe
  Версия приложения:    ...
  Отметка времени приложения:    ed4
  Имя модуля с ошибкой:    core83.dll
  Версия модуля с ошибкой:    ...
  Отметка времени модуля с ошибкой:    e4378d3
  Код исключения:    c0000005
  Смещение исключения:    e1
  Версия ОС:    .......
  Код языка:    
  Дополнительные сведения :    dd7
  Дополнительные сведения :    dd7b8209eb9a0e87dab712004954ef6
  Дополнительные сведения :    a1e
  Дополнительные сведения :    a1e52eef3fb6a8567f23164525a6c30

zak555

10 – 27.02.20 – 08:23

Руками загрузи последний cf

rashid

11 – 27.02.20 – 08:23

Загружал. Не помогает.

Sergz66

12 – 27.02.20 – 08:28

На другой комп базу скопируй и попробуй там.

rashid

13 – 27.02.20 – 08:29

Началось все еще раньше.
Я через конфиг загружал чистую конфу.
Через конфигуратор все нормально обновляется, как только в атомате – все косяк. Другая конфа сперва косяк дала -после повторно пошла, но обновилась.
На других компах другие базы иногда обновляются на автомате, а некоторые только через конфигуратор.
Сравниваю конфигурации – один к одному. Загружаю – тот же эфект 🙁

rashid

14 – 27.02.20 – 08:29

И копировал на другой – тот же эффект

Sergz66

15 – 27.02.20 – 08:31

Пробуй на другой версии/разрядности платформы. ТиИ сделай…

rashid

16 – 27.02.20 – 08:33

Где бы логи  подробнее посмотреть,  за чего то при выполнении скрипта add-delete-patches.js
Текстовый  templog.txt пустой.

Ошибка в строках лога

.. :: {OK} Выполнение обработчиков обновления (/)...
.. :: {OK} Запускается: wscript.exe; параметры: "C:\Users\RashidViktorovich\AppData\Local\Temp\Cv8Update.\add-delete-patches.js" /ConnectionString:"File='D:\Base\ГранитСтрой';Usr='';Pwd='******';UC=ПакетноеОбновлениеКонфигурацииИБ" /COMConnectorName:"v83.COMConnector" /FixFileNames:"" /RemoveFixNames:"" /Out:"C:\Users\RashidViktorovich\AppData\Local\Temp\Cv8Update.\templog.txt"; окно: SW_HIDE; ожидание: true
.. :: {ERR} Код возврата: -
.. :: {ERR} Исключение при вызове ОбновлениеКонфигурацииВызовСервера.ОбновитьИсправленияИзСкрипта: Error, Не удалось обновить исправления конфигурации. Подробности см. в предыдущей записи..

27.02.2020 15:19:14 {ERR} Завершение с ошибкой. Код ошибки: 2. Подробности см. в предыдущей записи.

rashid

17 – 27.02.20 – 08:34

Устанавливал и 64 разрядную  и обычную – ничего не помогло

GrandSportS

18 – 27.02.20 – 08:36

(0) Имхо косяк 16 платформы. Наблюдал не у одного клиента и именно на 16-той. В каждом случае помогало только обновление через конфигуратор и откат до 15 платформы. На ней все ок.

rashid

19 – 27.02.20 – 08:37

Обновление делал и на ... платформе
На  обновление в атомате  делается  - требует  - ю

Vstur

20 – 27.02.20 – 08:59

(19) ну, мало ли кто что требует.
БП 3.0 прекрасно работает на 14-й, очень пишет в мин. требованиях при запуске.

Вопрос → 
Ошибка обновления до релиза 2.0.39.40

Коллеги, добрый день!

При обновлении базы до релиза 2.0.39.40 возникает ошибка

https://yadi.sk/i/PiqK3C7Sn0zYSQ

Выполнение команд “Завершить работу” или “Перезапустить” не помогают: при запуске программы снова начинает выполняться обновление.

Подскажите, как прервать обновление?

Бата типовая, доработок нет.

Информация из журнала регистрации:

Значение не является значением объектного типа (Записать)
{РегистрСведений.Расписания.МодульМенеджера(18)}:        ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
{ОбщийМодуль.ОбновлениеИнформационнойБазыДеньги.Модуль(603)}:    РегистрыСведений.Расписания.ПерезаписатьШаблоны();
{(1)}:ОбновлениеИнформационнойБазыДеньги.Обновление_203933()
{ОбщийМодуль.ОбщегоНазначения.Модуль(5113)}:    Выполнить ИмяМетода + “(” + ПараметрыСтрока + “)”;
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(6318)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(Обработчик.Процедура, ПараметрыОбработчика);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2155)}:            ВыполнитьОбработчикОбновления(Обработчик, ПараметрыОбработчика, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(1707)}:            ИтерацияОбновления.ВыполненныеОбработчики = ВыполнитьИтерациюОбновления(ИтерацияОбновления, Параметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(93)}:    ВыполнитьДействияПриОбновленииИнформационнойБазы(ПараметрыОбновления, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2289)}:        Результат = ВыполнитьОбновлениеИнформационнойБазы(ПараметрыОбновления);
{(1)}:ОбновлениеИнформационнойБазыСлужебный.ВыполнитьОбновлениеИнформационнойБазыВФоне(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(5113)}:    Выполнить ИмяМетода + “(” + ПараметрыСтрока + “)”;
{ОбщийМодуль.ДлительныеОперации.Модуль(1036)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыВызова);
{ОбщийМодуль.ДлительныеОперации.Модуль(1026)}:        ВызватьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);
 


-2

Важенин Владимир ( Российская Империя)

01.05.2021 11:22

Три темы вниз не пробовали посмотреть? Вы плодите одинаковые сообщения.

А прервать можно через диспетчер задач


-3



Лушникова Анджелика

01.05.2021 11:26

Владимир, добрый день!

Если Вы взялись отвечать на вопросы, то может будете сразу указывать на подобные сообщения?

Что за манера отвечать вопросом на вопрос?

Какая из тем?

https://yadi.sk/i/0qTP_Rke6dN0QQ


-1

Важенин Владимир ( Российская Империя)

01.05.2021 11:59

Добрый день еще раз. Ну а как Вам еще ответить, если вы создаете тему сразу же за темой, которую рассматривали? Нет, я конечно понимаю, что может быть Вам лень читать соседние сообщения с названием вашей проблемы. Но почему вы хотите, что бы дублировали ответы в ваше сообщение?

https://forum.1c.ru/money/topic/14313 – название темы: “Нет синхронизации после обновления 20.04.21г”

https://forum.1c.ru/money/topic/14234 название темы: “Ошибка синхронизации после обновления 2.0.39.26”

https://forum.1c.ru/money/topic/14192 название темы: “Сломался обмен с мобильным приложением после обновления на 2.0.39.18.”

Вам лень почитать или продолжить обсуждение там? Ведь ясно, что проблема в версии 39 и ее не могут никак решить. Или вы хотите индивидуального подхода?


-2



Лушникова Анджелика

01.05.2021 12:16

Владимир, зачем описывать свою ошибку в чужой теме?

Вариант решения может быть другим.

Зачем отвлекать авторов чужих сообщений моей ошибкой? Им ведь рассылка моих комментариев на почту приходит.

И да, зачем мне читать чужие сообщения, если в их наименовании нет ничего похожего с моей проблемой.

И релиз другой, т.к. 20.04.2021 обновление у меня прошло успешно.

Сегодня система оповестила, что есть доступное обновление (2.0.39.40 от 29.04.2021). Я его запустила и получилось то, что получилось.

В диспетчере что отключать нужно? В каком диспетчере – Windows?

Если здесь, то не помогает. Запускаю 1С в режиме предприятия и снова запускается обновление.

http://joxi.ru/nAykbqXiwzX1jm


-3

Важенин Владимир ( Российская Империя)

01.05.2021 12:21

Ну и не читайте… Ждите у моря погоды…

Покидаю вашу тему


+3



Лушникова Анджелика

01.05.2021 23:20

Техподдержка 1С выслала обработку, если у кого возникла такая ошибка, исправляйте.

Ошибка возникает, если в базе остались расписания без шаблонов операций.

Обойти ошибку можно несколькими способами:

1. Восстановить информационную базу из резервной копии, открыть в ней внешнюю обработку из вложения и нажать кнопку “Проверить расписания шаблонов”. После этого можно обновить конфигурацию до последней версии.

2. Открыть информационную базу, в которой обновление не завершилось из-за ошибки. Дождаться появления сообщения об ошибке, после чего в меню “Еще” выбрать команду “Открыть внешнюю обработку”, открырь обработку из вложения и в ней нажать кнопку “Проверить расписания шаблонов”. По завершении проверки закрыть обработку и нажать кнопку “Перезапустить”. Информационная база будет перезагружена и обновление завершится.





iyurkin

02.05.2021 7:53

Добрый день!

благодарю за полезную информацию. у меня аналогичная проблема при обновлении конфигурации:

Значение не является значением объектного типа (ПолучитьОбъект)
{РегистрСведений.Расписания.МодульМенеджера(17)}:        ДокОбъект = ВыборкаДетальныеЗаписи.ВладелецРасписания.ПолучитьОбъект();
{ОбщийМодуль.ОбновлениеИнформационнойБазыДеньги.Модуль(603)}:    РегистрыСведений.Расписания.ПерезаписатьШаблоны();
{(1)}:ОбновлениеИнформационнойБазыДеньги.Обновление_203933()
{ОбщийМодуль.ОбщегоНазначения.Модуль(5113)}:    Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(6318)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(Обработчик.Процедура, ПараметрыОбработчика);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2155)}:            ВыполнитьОбработчикОбновления(Обработчик, ПараметрыОбработчика, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(1707)}:            ИтерацияОбновления.ВыполненныеОбработчики = ВыполнитьИтерациюОбновления(ИтерацияОбновления, Параметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(93)}:    ВыполнитьДействияПриОбновленииИнформационнойБазы(ПараметрыОбновления, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2289)}:        Результат = ВыполнитьОбновлениеИнформационнойБазы(ПараметрыОбновления);
{(1)}:ОбновлениеИнформационнойБазыСлужебный.ВыполнитьОбновлениеИнформационнойБазыВФоне(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(5113)}:    Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ДлительныеОперации.Модуль(1036)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыВызова);
{ОбщийМодуль.ДлительныеОперации.Модуль(1026)}:        ВызватьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);

с обработкой проблема:

“Нарушение прав доступа!”

UPD: Разобрался с правами, но обработка не работает: Значение не является значением объектного типа (ПолучитьОбъект)

Как исправить ошибку?


+1



Лушникова Анджелика

02.05.2021 8:35

Добрый день!

Пишите в техподдержку v8@1c.ru.

Достаточно быстро отвечают, не смотря на праздничные дни.

Успешный результат исправления ошибки можно сюда выложить. 🙂



Суханов Кирилл ( Санкт-Петербург)

18.05.2021 13:08

Добрый день так же не дает обновить до 2.0.39.44

Значение не является значением объектного типа (ПолучитьОбъект)
{РегистрСведений.Расписания.МодульМенеджера(17)}:        ДокОбъект = ВыборкаДетальныеЗаписи.ВладелецРасписания.ПолучитьОбъект();
{ОбщийМодуль.ОбновлениеИнформационнойБазыДеньги.Модуль(826)}:    РегистрыСведений.Расписания.ПерезаписатьШаблоны();
{(1)}:ОбновлениеИнформационнойБазыДеньги.Обновление_203943()
{ОбщийМодуль.ОбщегоНазначения.Модуль(5113)}:    Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(6318)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(Обработчик.Процедура, ПараметрыОбработчика);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2155)}:            ВыполнитьОбработчикОбновления(Обработчик, ПараметрыОбработчика, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(1707)}:            ИтерацияОбновления.ВыполненныеОбработчики = ВыполнитьИтерациюОбновления(ИтерацияОбновления, Параметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(93)}:    ВыполнитьДействияПриОбновленииИнформационнойБазы(ПараметрыОбновления, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2289)}:        Результат = ВыполнитьОбновлениеИнформационнойБазы(ПараметрыОбновления);
{(1)}:ОбновлениеИнформационнойБазыСлужебный.ВыполнитьОбновлениеИнформационнойБазыВФоне(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(5113)}:    Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ДлительныеОперации.Модуль(1036)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыВызова);
{ОбщийМодуль.ДлительныеОперации.Модуль(1026)}:        ВызватьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);


18.05.2021 13:06:26 {ERR} Завершение с ошибкой. Код ошибки: 1. Подробности см. в предыдущей записи.
18.05.2021 13:06:26 {OK} Восстановление информационной базы...
18.05.2021 13:06:26 {OK} Восстановление ИБ из временного архива
18.05.2021 13:06:26 {OK} База данных восстановлена из резервной копии
18.05.2021 13:06:26 {ERR} ОбновлениеНеВыполнено (обновление не выполнено)
18.05.2021 13:06:26 {OK} Запускается: C:\Program Files (x86)\1cv8\8.3.17.2198\bin\1cv8c.exe; параметры: ENTERPRISE /F"C:\Mone" /N"Кирилл" /P"******" /WA- ; окно: SW_SHOW; ожидание: false
18.05.2021 13:06:27 {OK} Код возврата: 0

Пробовал 1 и 2 пункт не помогло

Показ сообщения об ошибке

Для вывода сообщения об ошибке нужно использовать функцию ОписаниеОшибки();

Пример:

Попытка
    НаборЗаписей.Записать(Истина);
Исключение
    Сообщить(ОписаниеОшибки());
КонецПопытки;

Для выдачи структуированной информации об ошибке в версии 8.2 служит функция ИнформацияОбОшибке().

    Инфо = ИнформацияОбОшибке();
    Сообщить("" + Инфо.Описание + "");
    Сообщить("" + Инфо.ИмяМодуля + "");
    Сообщить("" + Инфо.НомерСтроки);
    Сообщить("" + Инфо.ИсходнаяСтрока + "");

Вызов исключения

В 1С:Предприятие 7.7 оператор ВызватьИсключение; служит для повторного вызова исключения из блока Исключение-КонецПопытки. Для вызова из других частей программы можно использовать внешнюю компоненту или деление на 0, например а=1/0.

В 1С:Предприятие версии 8 есть оператор ВызватьИсключение:

ВызватьИсключение "Текст сообщения об ошибке";

Не обновляется конфигурация Розница базовая с 2. 30 на 2

Здравствуйте. Не получается обновить конфигурацию 1С розница базовая 2.2.12.30 на 2.2.13.12.

Результаты обновления программы:
Во время обновления программы возникли некоторые проблемы.
Информация о них сохранена в журнал регистрации.

Информация для технической поддержки:
Текст лог-файла.
Название программы: Розница (базовая), редакция 2.2
Версия программы: 2.2.12.30;
Версия Платформы 1С:Предприятие: 8.3.15.1565 Windows x86;
Версия Библиотеки стандартных подсистем: 3.0.2.269;
Операционная система: Microsoft Windows 10 version 10.0 (Build 17763);
Размер оперативной памяти: 3*471;
Имя COM соединителя: v83.COMConnector;
Базовая: Да
Полноправный пользователь: Да
Учебная: Нет
Конфигурация изменена: Нет

Подскажите, что не так делаю?
Ваше сообщение
Заголовок:
Не обновляется конфигурация Розница базовая с 2.2.12.30 на 2.2.13.12

Здравствуйте. Не получается обновить конфигурацию 1С розница базовая 2.2.12.30 на 2.2.13.12.

Результаты обновления программы:
Во время обновления программы возникли некоторые проблемы.
Информация о них сохранена в журнал регистрации.

Информация для технической поддержки:
Текст лог-файла.
Название программы: Розница (базовая), редакция 2.2
Версия программы: 2.2.12.30;
Версия Платформы 1С:Предприятие: 8.3.15.1565 Windows x86;
Версия Библиотеки стандартных подсистем: 3.0.2.269;
Операционная система: Microsoft Windows 10 version 10.0 (Build 17763);
Размер оперативной памяти: 3*471;
Имя COM соединителя: v83.COMConnector;
Базовая: Да
Полноправный пользователь: Да
Учебная: Нет
Конфигурация изменена: Нет

Подскажите, что не так делаю?

Как исправить ошибку?

burluckoff сказал(-а):

17.09.2019 02:39

Не обновляется конфигурация Розница базовая с 2. 30 на 2

Сообщение от binion

Подскажите, что не так делаю?

1. Живёте и работаете не в той стране!;
2. Используете продукцию 1С;
3. Используете управляемую конфу;
4. Пытаетесь обновиться автоматом.

Как исправить ошибку?

BloodNerd сказал(-а):

08.10.2019 10:19

Не обновляется конфигурация Розница базовая с 2. 30 на 2

Сообщение от binion

Здравствуйте. Не получается обновить конфигурацию 1С розница базовая 2.2.12.

Подскажите, что не так делаю?

Не видит обновление…
Вполне реально, что 1с затупила и скачала версию проф, вместо базовой…уже было как-то, сделай резервную копию и обновляй через конфигуратор.

Как исправить ошибку?

Kirill001 сказал(-а):

08.10.2019 11:21

Не обновляется конфигурация Розница базовая с 2. 30 на 2

Сообщение от BloodNerd

Нет, дело не в этом, 1с накосячила с обновлением, и в правду, в большинстве случаев если стоит розница базовая 2.2 не получиться обновиться с .2.12.30 на 2.2.13.12 .
Решение такое, устанавливаем чистый шаблон 2.2.13.12, выгружает от туда конфигурационный файл и накатывает на базу с 2.2.12.30

ОШИБКА ПРИ ОБНОВЛЕНИИ ЗУП

Люди, подскажите пожалуйста в чем проблема может быть – уже неделю бьюсь.. :confused:Обновила ЗУП до релиза 2.5.58.1. При обновлении на 2.5.59.1 или 2.5.59.2 пишет что “Неудалось произвести обновление!” В журнале регистрации пишет :
1)Tue Feb 12 15:37:08 UTC+0400 2013 {ERR} Запускаемый файл не существует: C:\Users\work2\AppData\Local\1C\1Cv8Update\adv\ind ex.htm
2)Tue Feb 12 15:40:15 UTC+0400 2013 {ERR} Код возврата: 1
3) Для выполнения команды требуется разблокировать все объекты.

Как исправить ошибку?

juliko сказал(-а):

12.02.2013 22:57

Библиотека стандартных подсистем. Версия 1. Информация об ошибках

Если Не ЕстьАлгоритмПоиска Тогда

// сам поиск непосредственно и без алгоритма поиска СсылкаНаОбъект = НайтиЭлементПоСвойствамПоиска(ТипОбъекта, ИмяТипаОбъекта, СвойстваПоиска, СтруктураСвойств, СтрокаИменСвойствПоиска, ПоискПоДатеНаРавенство);

КонецЕсли;

написать код

Если Не ЕстьАлгоритмПоиска Тогда

// сам поиск непосредственно и без алгоритма поиска СсылкаНаОбъект = НайтиЭлементПоСвойствамПоиска(ТипОбъекта, ИмяТипаОбъекта, СвойстваПоиска, СтруктураСвойств, СтрокаИменСвойствПоиска, ПоискПоДатеНаРавенство); // ОбъектНайден = ЗначениеЗаполнено(СсылкаНаОбъект);

КонецЕсли;

ИначеЕсли ИмяРеквизита = “Owner” Тогда Возврат НСтр(“ru = ‘Владелец’; en=’Owner'”);

1. Создать Пользователь1, Пользователь2 и Руководитель1.
2. В группу доступа “Работа с входящими и исходящими документами”
включить Пользователь1, по всем видам доступа поставить
Все разрешены, без исключений, кроме вида доступа Пользователи
– поставить Все запрещены, добавить значение Пользователь1.
3. Создать Подразделение1, выбрать руководителем подразделения
пользователя Руководитель1.
4. Создать входящие документы Док1 и Док2.
В личный доступ Док0 поставить Руководитель1
В личный доступ Док1 поставить Пользователь1
В личный доступ Док2 поставить Пользователь2
5. Войти под пользователем Пользователь1
Видны документы Док0 и Док1
6. Убрать в группе доступа разрешенное значение
Пользователь1
7. Обновить список входящих документов –
виден документ Док1

При этом кнопка “Исправить” не помогает.

{Обработка.СопоставлениеОбъектовИнформационныхБаз.МодульОбъекта(979)}: Ошибка при вызове метода контекста (Выполнить)
Запрос.Выполнить();
по причине:

по причине:
{(19, 27)}: Ожидается выражение “(“
ТаблицаИсточникаПараметр. <<?>>КАК ,

{ОбщийМодуль.ОбновлениеИнформационнойБазыКлиент.Модуль(28)}: При обновлении информационной базы возникла ошибка:

{ОбщийМодуль.ОбменДаннымиСервер.Модуль(686)}: При обновлении правил обмена данными возникли ошибки!
ВызватьИсключение НСтр(“ru = ‘При обновлении правил обмена данными возникли ошибки!'”);

Подробности см. в Журнале регистрации. ВызватьИсключение ТекстСообщенияОбОшибке;

Ошибка при выполнении обработчика – ‘ПередЗаписью’
по причине:
{ОбщийМодуль.ОбменДаннымиСобытия.Модуль(676)}: Ошибка при вызове метода контекста (ПолучитьЗначенияСвойствДляСсылки)
ЗаписатьВФорме();
по причине:
Попытка передачи с клиента на сервер мутабельного значения 2-го параметра метода ПолучитьЗначенияСвойствДляСсылки ().

Необходимо иметь в виду эту особенность поведения при разработке ограничений доступа.

ИначеЕсли ТипОбработки = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительныйОтчет Тогда

должно быт:

ИначеЕсли ТипОбработки = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет Тогда

Возврат ДоступноеОбновление.ИмяСтраницы;

Процедура ПроверитьНомерОбъектаПоДатеИОрганизации(Объект)

Если Объект.ЭтоНовый() Тогда Возврат; КонецЕсли;

МетаданныеОбъекта = Объект.Метаданные();

ТекстЗапроса = “
|ВЫБРАТЬ
| ШапкаОбъекта.Дата КАК Дата,
| ЕСТЬNULL(ШапкаОбъекта.Организация.Префикс, “”””) КАК ПрефиксОрганизацииДоИзменения
|ИЗ
| ” + МетаданныеОбъекта.ПолноеИмя() + ” КАК ШапкаОбъекта
|ГДЕ
| ШапкаОбъекта.Ссылка = &Ссылка
|”;

Запрос = Новый Запрос(ТекстЗапроса); Запрос.УстановитьПараметр(“Ссылка”, Объект.Ссылка);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда

ПрефиксОрганизацииПослеИзменения = ПолучитьФункциональнуюОпцию(“ПрефиксыОрганизаций”, Новый Структура(“Организация”, Объект.Организация));

// если задана пустая ссылка на организацию ПрефиксОрганизацииПослеИзменения = ?(ПрефиксОрганизацииПослеИзменения = Ложь, “”, ПрефиксОрганизацииПослеИзменения);

Если Выборка.ПрефиксОрганизацииДоИзменения &lt;&gt; ПрефиксОрганизацииПослеИзменения Тогда

Объект.Номер = “”;

ИначеЕсли Не ДатыОбъектаОдногоПериода(Выборка.Дата, Объект.Дата, МетаданныеОбъекта) Тогда

Объект.Номер = “”;

КонецЕсли;

КонецЕсли;

КонецПроцедуры

Поле объекта не обнаружено (ИнформационнаяБазаЗаблокированаДляОбновления)
Подробно:
{ОбщийМодуль.ОбновлениеИнформационнойБазыКлиент.Модуль(47)}: Поле объекта не обнаружено (ИнформационнаяБазаЗаблокированаДляОбновления)
Результат = СтандартныеПодсистемыКлиентПовтИсп.ПараметрыРаботыКлиента().ИнформационнаяБазаЗаблокированаДляОбновления;

<время> {OK } Запускается: C:\Program Files (x86)\1cv82\8.2.13.219\bin\1cv8.exe; параметры: CONFIG /S”имя базы” /N”Пользователь” /P”*****” /WA- /UpdateDBCfg /Out “templog.txt” /UCПакетноеОбновлениеКонфигурацииИБ /DisableStartupMessages; окно: SW_SHOW; ожидание: true
<время> {ERR} Код возврата: 1
Обработка структуры базы данных…

Обработка структуры базы данных…

Ошибка исключительной блокировки информационной базы.Активны сеансы:компьютер: &lt;имя машины&gt;, сеанс: 30, начат: &lt;время&gt;, приложение: COM-соединение

<время> {ERR} Завершение с ошибкой. Код ошибки: 1. Подробности см. в предыдущей записи.

заменить фрагмент кода

if (result != -1)
{
connection = null;
CollectGarbage(); // освобождает соединения с COM-объектом
}
на

if (result != -1)
{
ComConnection = null;
connection = null;
CollectGarbage(); // освобождает соединения с COM-объектом
}

// если префикс не задан, то устанавливаем значение по умолчанию Если ПустаяСтрока(Префикс) Тогда

Префикс = “0”;

КонецЕсли;

Ошибка не влияет на результат присвоения префикса номеру/коду объекта.

Если Субконто = Неопределено ИЛИ НайтиПравило(Субконто) = Неопределено Тогда

Продолжить;

КонецЕсли;

на

Если Субконто = Неопределено ИЛИ НайтиПравило(Субконто, ИмяПКО) = Неопределено Тогда

Продолжить;

КонецЕсли;

Заменить:

ПКОЗначение = НайтиПравило(Субконто);на

ПКОЗначение = НайтиПравило(Субконто, ИмяПКО);

на запрос:

Запрос = Новый Запрос(
“ВЫБРАТЬ
| НовыеРодители.ТолькоВидДоступа,
| НовыеРодители.ГруппаДоступа
|ПОМЕСТИТЬ НовыеРодители
|ИЗ
| &НовыеРодители КАК НовыеРодители
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| СтарыеРодители.ТолькоВидДоступа,
| СтарыеРодители.ГруппаДоступа
|ПОМЕСТИТЬ СтарыеРодители
|ИЗ
| РегистрСведений.ГруппыЗначенийДоступа КАК СтарыеРодители
|ГДЕ
| СтарыеРодители.ВидДоступа = &ВидДоступа
| И СтарыеРодители.ЗначениеДоступа = &ЗначениеДоступа
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ ПЕРВЫЕ 1
| ИСТИНА КАК ЗначениеИстина
|ИЗ
| СтарыеРодители КАК СтарыеРодители
| ЛЕВОЕ СОЕДИНЕНИЕ НовыеРодители КАК НовыеРодители
| ПО (НовыеРодители.ТолькоВидДоступа = СтарыеРодители.ТолькоВидДоступа)
| И (НовыеРодители.ГруппаДоступа = СтарыеРодители.ГруппаДоступа)
|ГДЕ
| НовыеРодители.ГруппаДоступа ЕСТЬ NULL
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ ПЕРВЫЕ 1
| ИСТИНА
|ИЗ
| НовыеРодители КАК НовыеРодители
| ЛЕВОЕ СОЕДИНЕНИЕ СтарыеРодители КАК СтарыеРодители
| ПО НовыеРодители.ТолькоВидДоступа = СтарыеРодители.ТолькоВидДоступа
| И НовыеРодители.ГруппаДоступа = СтарыеРодители.ГруппаДоступа
|ГДЕ
| СтарыеРодители.ГруппаДоступа ЕСТЬ NULL “);

Читайте также:  Причины возникновения кодов ошибок приборной панели Нива Шевроле 8 и способы их устранения

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *